Menu Sign In Contact FAQ
Banner
Welcome to our forums

High EGT after cylinder replacement

Hi,

I had to pull one of the cylinders due to a burned exhaust valve and my mechanic replaced it with an overhauled one. During the engine run he said that the EGT on this particular cylinder was running 300° hotter than all the others and he said that this was not good. He checked the injectors and said they were all good. I did not have this EGT imbalance before changing the cylinder so I wonder why it should be a fuel delivery issue.
The cylinder that had been pulled had some very visible chafing on one side of the wall and one valve was burnt.
I picked up my TB21 from the annual where the compressions were checked and 2 cylinders had values in the mid 60s. I flew back home and things seemed normal. The next day upon run up and mag check the engine would run rough on one mag so initially we thought it would be an ignition problem. Spark plugs were checked and found ok, magneto sent to the overhaul shop and found ok so they looked at the cylinder and made a compression check again and it was 0. How can a cylinder go from mid 60s to 0 in 3 hours of flight. What could be the cause for the chafing, a badly seated piston ring?
what could have caused the spike in EGT after the exchange of the cylinder?

I’d appreciate any hints and input.

Last Edited by placido at 05 May 06:44
LSZH

Assuming he actually checked the injector properly, I would replace the fuel line to it, and then the distributor. Not expensive.

Administrator
Shoreham EGKA, United Kingdom

Small particles inside the injector are remarkably hard to shift, I have had similar problems with an O-540, the high EGT can be picked up even on the ground at RPM’s a bit above ideal using a laser thermometer as you run the engine without the cowl fitted.

Only with repeated untrasonic cleaning of the injector did we clear the problem, the ability of the dirt to stay inside the injector was remarkable and it took three or four passes through the untrasonic cleaner to remove what was remarkably little dirt.

Peters comments about replacing the injector, fuel line and distributor do have merit as the cost of the parts could well be exceeded by that of the Labour time resolving the issue by cleaning the original parts.

Last Edited by A_and_C at 05 May 08:07

If you did not have an engine monitor, you would not “know” that the EGT was 300°F hotter than the others, so you would need to take your clues from elsewhere. Are there any other indications making you think that something is wrong with the engine?

At run-up, an EGT delta of 300°F is a lot. Even if one plug is not firing at all on a cylinder, you should not see the EGT go as high as 300°F hotter than with two plugs firing. With my limited knowledge and experience, I can only think of 3 reasons for such a reading:

  1. The exhaust valve is leaking badly
  2. The EGT reading is incorrect
  3. The cylinder is running leaner than the others

You should be able to eliminate #1 with a compression test.
And you should be able to determine if it is #2 or #3 by answering the following questions (although again I believe that #3 is unlikely due to the magnitude of the delta):

  • If one cylinder has that much higher EGT than normal, that would reflect on the TIT. Is it the case?
  • How does the EGT on that cylinder change with mixture compared to the others?
  • If that cylinder is really running much leaner than the others, you would expect that it would peak first when you lean, or maybe even shut off. Even at run-up power you should be able to find the EGT peaks.
  • EGT probes are relatively cheap. Could you replace the EGT probe on that cylinder and see what it does, or swap two EGT probes?
  • Does the engine run smooth including at run-up when you lean to peak EGT with reference to the readings of the “normal” cylinders?

Engine monitors are great, but you always need to keep in mind that you could get a false reading.

Last Edited by at 05 May 09:12
LFPT, LFPN

Thanks all

I will relay to my mechanic and see what he thinks. I have not run the engine myself so I have no clue.

LSZH

You should not leave all that troubleshooting solely to your mechanic. Get over there and see what is happening for yourself.

You know your engine best. You know what temperatures you normally see during a run-up, or, since you have an engine monitor, you should be able to look it up in prior data downloaded from your engine monitor. So you should know, or be able to find out, what TIT you typically see during a run-up and compare it to what you see now – for example.

Last Edited by at 05 May 14:11
LFPT, LFPN

If the engine is ‘cold’ and not running, do all EGTs show the same ambient temperature?

EBKT

Placido, you are a pilot and your life hangs on this.

Most mechanics don’t know anything about flying and even less about engine management. You need to get involved.

Dirk’s tip above is the first thing.

Administrator
Shoreham EGKA, United Kingdom

I am away this week and cannot get to the aircraft. I will talk to the mechanic about your suggestions.

LSZH

A very common error is to have the starwasher NOT between the lugs where the probe connects to the harness. This will give unstable readings.

EBKT
130 Posts
Sign in to add your message

Back to Top