Menu Sign In Contact FAQ
Banner
Welcome to our forums

Anyone has a KN63 DME lying around?

This is the remotely controlled one, which uses a KDI572.

Administrator
Shoreham EGKA, United Kingdom

Shame – I have a surplus panel-mount KN64.

Avionics geek.
Fairoaks. EGTF

Yes, complete system all with EASA form 1

I have one coming from the US for $900 for both the KN63 and a spare KDI572.

Administrator
Shoreham EGKA, United Kingdom

I got the two boxes from the US.

The good news is that the DME works, so I have a spare DME, new list price $13k

The bad news is that the fault remains, but – as before – appears only after about 20 mins, so is probably temperature dependent. It is most likely the KDI572, which I also got, but it arrived with a broken display. So I am looking for a KDI572…

What is interesting is that the DME reading also disappears on the Sandel SN3500 (which taps into the DME wiring to get that data). I need to find out whether the clock+data is generated by the KN63 or the KDI572. If the latter, that confirms my view above.

What is more interesting is that the morse code ident also disappears when the “DME” fails. This is the case for both radios and both source selections on the KDI572. So if it is the KDI572, that suggests that the KDI572 is somehow doing the ident also. Unfortunately I don’t have a MM for the KDI572. I do have the KN63 MM which is ~ 500 pages

However the KDI572 has no audio or UHF circuitry so I reckon the ident must come out of the KN63, because the KX radios aren’t going to have a receiver section for the DME UHF frequency. All they do is send the NAV channel number to the KN63, which contains the UHF tuner, which extracts the ident. That in turn suggests that if the fault is the KDI572, this might be sending some duff data to the KN63 and this mis-tunes it.

Administrator
Shoreham EGKA, United Kingdom

Could you, in theory, replace the KDI with the one with the malfunctioning display, and see the data on the Sandel? If only the display is broken, perhaps the rest of the unit works.

tmo
EPKP - Kraków, Poland

I was thinking exactly that yesterday

It would narrow down the issue very quickly.

Reading the IMs, it looks like a KX radio sends a sync serial (clock+data) stream to the KDI572, probably BCD (the IM shows the encoding) which the KDI572 decodes and sends to the KN63 (via a second clock+data serial connection; protocol unknown but likely BCD also) for tuning it.

Administrator
Shoreham EGKA, United Kingdom

@tmo was spot on. No display but it works perfectly.

Administrator
Shoreham EGKA, United Kingdom
8 Posts
Sign in to add your message

Back to Top