Menu Sign In Contact FAQ
Banner
Welcome to our forums

Repair of King luminescent / gas discharge displays, and LED replacements

The bottom segment on all digits is half-dim, though it improved as it worms up. The decimal point on the distance is missing.

I believe it is a KDI572 or KDI573.

A new one costs a few k! I belive it is just a simple box fed with RS232.

Administrator
Shoreham EGKA, United Kingdom

Sometimes this is due to a bad contact on the display. Just take it out and clean the contacts .

FAA A&P/IA
LFPN

I have to agree with Michael, the first thing to do is to clean the contacts on the display. It works most of the time.

Last Edited by A_and_C at 19 Dec 19:28

I hope you will let us know if it works @Peter
I have the same problem with the digit of my ADF screen (the classical Bendix) and I was proposed to change the screen for 500€ approx. which I refused.
Usually, only the lower digits are concerned (the bottom line) and things improve when it s getting warm.
Will try to get a photo.

Do we have to take all the unit out to disconnect the display ?

Yes I think so.

I will get this done at the Annual in January. Myself and my A&P/IA will be renting a hangar at a certain location in the UK because nothing can be done where I am based.

The display is multiplexed and the issue is either a bad connection to the display itself, or a duff driver chip. The chips are probably easily changed – unless they rubbed off the markings. I may have the MM in my collection and I have a contact who can get me any King MM.

Administrator
Shoreham EGKA, United Kingdom

Peter wrote:

a bad connection to the display itself,

This is a very well known issue with the Bendix/King gas discharge displays.

FAA A&P/IA
LFPN

I think my DME has acquired an internet connection. I can see the logins into EuroGA, and here is the result

Administrator
Shoreham EGKA, United Kingdom

So what have you done Peter?

LFPE

Nothing

Administrator
Shoreham EGKA, United Kingdom
68 Posts
Sign in to add your message

Back to Top