Menu Sign In Contact FAQ
Banner
Welcome to our forums

Search Function and the colon?

I usually check with the search function before creating a new topic, so that I don’t duplicate a thread unnecessarily.

Today I was looking for anything about the US government shutdown, so searched for “shutdown”.
It only came up with engine-related stoppages, nothing about the topic at all.

So I was a bit surprised after posting to find out that there was already a thread with that word in the title from the previous week or two.
US government shutdown: impact on Aviation?

I’m guessing the semi-colon may have confused the search engine, but it’s a shame that it didn’t (and as of now, still doesn’t) show up.

By the way, searching for shutdown: (with the semicolon) crashes the search engine (using the box on the home page middle top right)

Oops. Something isn’t right

Try following links from the home page. If it still doesn’t work please do get in touch and quote reference 036c55320.
EGBJ, United Kingdom

Maybe David has fixed it but I have just searched for

shutdown

and this is the top result, so it looks like it is working.

I am not sure what triggers a re-index of the search database but I would expect the creation of a new thread to be one of the triggers.

Administrator
Shoreham EGKA, United Kingdom

The topic you’ve listed is the new one that I created. As you say, it does show up on a search, however the previous shutdown article which I linked to doesn’t. Even a search for “impact” doesn’t find this article – looks like it just didn’t make it into the index.

I wondered if it is a one-off or more general issue. There’s a huge amount of useful information and insight on Euroga, so I would argue the search function is quite important.

EGBJ, United Kingdom

I suspect the colon has messed up the search index creation, because I edited the subject to remove it (replaced it with a dash with spaces around it) and it still doesn’t come up on e.g.

shutdown AND impact

but it may come up a bit later…

Funnily enough the above search finds this thread (because it contains both words) but not the original thread.

Curious, because my understanding (and experience) is that editing the subject of a thread (which I do fairly often, as admin) triggers a re-index. But maybe it doesn’t and the newly edited thread appears in the search results because it contains the old terms already.

Administrator
Shoreham EGKA, United Kingdom

By the way, searching for shutdown: (with the -semi-colon) crashes the search engine

Nobody likes having their colon searched.

The reason for the server having a meltdown in this case is because the colon is used for some advanced search facilities, whereby you specify field: value. So if you just put field: it makes no sense. I’ve improved the error message so that it tells you that if you try it.

Threads are reindexed immediately, there is no waiting period, if everything is working properly. However, they do happen asynchronously so you’re not having to wait for your page to be returned, i.e. they’re added to a queue and done in the background. But that queue is ordinarily so short it happens almost instantly. Editing a thread title does cause the thread to be reindexed.

The bug whereby the thread wasn’t originally indexed is fixed, plus Peter now has some extra tools to help him if this were to happen again.

Administrator
EGTR / London, United Kingdom
5 Posts
Sign in to add your message

Back to Top